Draws not appearing in Draw Management tab (Construction Financials)

Incident Report for Built

Resolved

As of 12:38 PM CT we’ve confirmed full resolution of the incident causing owners using Construction Financials to not see their draws in the draw management tab, beginning at roughly 10:45 AM CT on 11/3.

Thank you for your patience. We apologize for any inconvenience this caused.
Posted Nov 03, 2025 - 13:00 CST

Identified

We have identified the cause of the incident causing owners using Construction Financials to not see their draws in the draw management tab, beginning at roughly 10:45 AM CT on 11/3. We are working on a solution that will restore full functionality.

We apologize for any inconvenience and will keep you informed as we have more information. Thank you for your understanding as we work to resolve the issue.
Posted Nov 03, 2025 - 11:17 CST
This incident affected: Built for Construction (Authentication and User Management).