As of March 5, 2026 at 10:45 AM CT, we’ve confirmed full resolution of the registration process issues impacting sponsored builders and borrowers invited to CLA that began at approximately 2:00 PM CT on March 4, 2026.
During this time, some builders and borrowers may have experienced errors or been unable to complete registration. The underlying issue has been corrected, and the registration flow is now functioning as expected.
We recommend that any users who attempted to register during the incident and were unsuccessful retry the registration process using their original invitation link. If issues persist, please reach out to Support for assistance.
Thank you for your patience. We apologize for any inconvenience this caused.
Resolved
As of March 5, 2026 at 10:45 AM CT, we’ve confirmed full resolution of the registration process issues impacting sponsored builders and borrowers invited to CLA that began at approximately 2:00 PM CT on March 4, 2026.
During this time, some builders and borrowers may have experienced errors or been unable to complete registration. The underlying issue has been corrected, and the registration flow is now functioning as expected.
We recommend that any users who attempted to register during the incident and were unsuccessful retry the registration process using their original invitation link. If issues persist, please reach out to Support for assistance.
Thank you for your patience. We apologize for any inconvenience this caused.
Identified
We have identified the cause of the incident causing registration process issues for builders and borrowers invited to CLA beginning at roughly 2:00 PM CT on March 4, 2026. We are working on a solution that will restore full functionality.
We apologize for any inconvenience and will keep you informed as we have more information. Thank you for your understanding as we work to resolve the issue.