As of 4:40 PM CT on 3/31/2026 we’ve confirmed full resolution of the issues with manually uploading signed waivers and importing new waivers via Excel/CSV import impacting our legacy lien waivers solution (lienwaivers.io), beginning on 3/24/2026.
Thank you for your patience. We apologize for any inconvenience this caused.
Resolved
As of 4:40 PM CT on 3/31/2026 we’ve confirmed full resolution of the issues with manually uploading signed waivers and importing new waivers via Excel/CSV import impacting our legacy lien waivers solution (lienwaivers.io), beginning on 3/24/2026.
Thank you for your patience. We apologize for any inconvenience this caused.
Monitoring
At approximately 4:15 PM CT 3/31/2026 we implemented a fix for the incident that caused issues with manually uploading signed waivers and importing new waivers via Excel/CSV import, impacting our legacy lien waivers solution (lienwaivers.io), starting at 2:00 PM CT 3/31/2026. We are closely monitoring the situation to ensure the issue is fully resolved.
Thank you for your patience during this time. We apologize for any inconvenience this has caused.
Investigating
We are currently investigating the cause of an incident identified at approximately 2:00 PM CT on 3/31/2026 impacting our legacy lien waivers solution (lienwaivers.io), causing issues with manually uploading signed waivers and importing new waivers via Excel/CSV import.
At this time we do not know the cause of the incident or have an estimated time for resolution. We will provide updates as we have them, and we appreciate your patience while we work to resolve the issue.