As of 8:10 AM CT on 4/23/2026 we’ve confirmed full resolution of the loading issues impacting our legacy lien waivers platform beginning at roughly 3:45 PM CT on 4/22/2026.
Thank you for your patience. We apologize for any inconvenience this caused.
Resolved
As of 8:10 AM CT on 4/23/2026 we’ve confirmed full resolution of the loading issues impacting our legacy lien waivers platform beginning at roughly 3:45 PM CT on 4/22/2026.
Thank you for your patience. We apologize for any inconvenience this caused.
Investigating
We are currently investigating the cause of an incident identified at 7:45 AM CT on 4/23/2026 impacting our legacy lien waivers platform, causing issues loading the application.
At this time we do not know the cause of the incident or have an estimated time for resolution. We will provide updates as we have them, and we appreciate your patience while we work to resolve the issue.