At approximately 9:40 AM CT on June 17, 2026, we implemented a fix for the incident that caused reporting to be inaccessible across Built products beginning at roughly 7:00 AM CT on June 17, 2026. We are closely monitoring the situation to ensure the issue is fully resolved.
No action is required from your team at this time. Reporting should now be accessible across all reporting tabs. Please note that Scheduled Exports were not impacted during this incident and all scheduled reports were delivered as expected.
If you continue to experience issues, please reach out to your Built support contact.
Thank you for your patience during this time. We apologize for any inconvenience this has caused.
Monitoring
At approximately 9:40 AM CT on June 17, 2026, we implemented a fix for the incident that caused reporting to be inaccessible across Built products beginning at roughly 7:00 AM CT on June 17, 2026. We are closely monitoring the situation to ensure the issue is fully resolved.
No action is required from your team at this time. Reporting should now be accessible across all reporting tabs. Please note that Scheduled Exports were not impacted during this incident and all scheduled reports were delivered as expected.
If you continue to experience issues, please reach out to your Built support contact.
Thank you for your patience during this time. We apologize for any inconvenience this has caused.
Investigating
We are currently investigating the cause of an incident identified at 7 AM CT on 6/17 impacting reporting across all Built products, rendering Reporting inaccessible for some users. However, it appears that scheduled reports are still being delivered.
At this time we do not know the cause of the incident or have an estimated time for resolution. We will provide updates as we have them, and we appreciate your patience while we work to resolve the issue.