As of 3:05 PM CDT on June 29, 2026 we've confirmed full resolution of the draw request submission issues impacting the CLA borrower portal beginning at roughly 2:00 PM CDT on June 29, 2026.
Action required: If you attempted to submit a draw request during the outage window and received a "Failed to submit draw(s)" error, please refresh your browser session and re-submit your draw request. Draw requests that failed during the incident were not saved and will need to be re-entered.
Thank you for your patience. We apologize for any inconvenience this caused.
Resolved
As of 3:05 PM CDT on June 29, 2026 we've confirmed full resolution of the draw request submission issues impacting the CLA borrower portal beginning at roughly 2:00 PM CDT on June 29, 2026.
Action required: If you attempted to submit a draw request during the outage window and received a "Failed to submit draw(s)" error, please refresh your browser session and re-submit your draw request. Draw requests that failed during the incident were not saved and will need to be re-entered.
Thank you for your patience. We apologize for any inconvenience this caused.
Monitoring
At approximately 2:55 PM CDT on June 29, 2026 we implemented a fix for the incident that caused draw request submission issues across the CLA borrower portal beginning at roughly 2:00 PM CDT on June 29, 2026. We are closely monitoring the situation to ensure the issue is fully resolved.
Action required: If you attempted to submit a draw request during the outage window and received a "Failed to submit draw(s)" error, please refresh your browser session and re-submit your draw request. Draw requests that failed during the incident were not saved and will need to be re-entered.
Thank you for your patience during this time. We apologize for any inconvenience this has caused.
Identified
We have identified the cause of the incident causing draw request submission issues across the CLA borrower portal beginning at roughly 2:00 PM CDT on June 29, 2026.
We are working on a solution that will restore full functionality.We apologize for any inconvenience and will keep you informed as we have more information. Thank you for your understanding as we work to resolve the issue.
Investigating
We are currently investigating the cause of an incident identified at 2:00 PM CDT on June 29, 2026 impacting the Built borrower portal (CLA), causing issues with draw request submissions - users are unable to complete draw submissions and receive an error when clicking "Submit".
At this time we do not know the cause of the incident or have an estimated time for resolution. We will provide updates as we have them, and we appreciate your patience while we work to resolve the issue.