An incident was identified at 1:42 PM Central on Fri, 8/7, affecting Construction Financials and Lien Waiver Compliance and Payments due to a third-party vendor issue, with impacts to document signing and downloading. As of 5:24 PM Central on 8/7, we believe the issue has been resolved. We will continue to monitor the situation, and we appreciate your patience. We apologize for any inconvenience this may have caused.
Monitoring
An incident was identified at 1:42 PM Central on Fri, 8/7, affecting Construction Financials and Lien Waiver Compliance and Payments due to a third-party vendor issue, with impacts to document signing and downloading. As of 5:24 PM Central on 8/7, we believe the issue has been resolved. We will continue to monitor the situation, and we appreciate your patience. We apologize for any inconvenience this may have caused.
Monitoring
An incident was identified at 1:42 PM Central on Fri, 8/7, affecting Construction Financials and Lien Waiver Compliance and Payments due to a third-party vendor issue, with impacts to document signing and downloading. As of 5:24 PM Central on 8/7, we believe the issue has been resolved. We will continue to monitor the situation, and we appreciate your patience. We apologize for any inconvenience this may have caused.