As of 9:52 AM CST on August 24, 2026, we've confirmed resolution of the email notification delivery issues that began at roughly 7:45 AM CST on August 24, 2026.
We are now working to resend any email notifications that weren't sent during the incident. No action is needed on your end.
Thank you for your patience. We apologize for any inconvenience this caused.
Resolved
As of 9:52 AM CST on August 24, 2026, we've confirmed resolution of the email notification delivery issues that began at roughly 7:45 AM CST on August 24, 2026.
We are now working to resend any email notifications that weren't sent during the incident. No action is needed on your end.
Thank you for your patience. We apologize for any inconvenience this caused.
Identified
We have identified the cause of the incident causing email notification delivery issues beginning at roughly 7:45 AM CST on August 24, 2026. Any emails or notifications that failed to send during this time will be automatically retried once the issue is resolved.
We apologize for any inconvenience and will keep you informed as we have more information. Thank you for your understanding as we work to resolve the issue.
Identified
We have identified the cause of the incident causing email notification delivery issues beginning at roughly 7:45 AM CST on August 24, 2026.
We apologize for any inconvenience and will keep you informed as we have more information. Thank you for your understanding as we work to resolve the issue.
Investigating
We are currently investigating the cause of an incident identified at 7:45 AM CST on August 24, 2026, impacting email notifications, password resets, alerts, scheduled reports, and other email notifications to fail to send.
At this time we do not know the cause of the incident or have an estimated time for resolution. We will provide updates as we have them, and we appreciate your patience while we work to resolve the issue.