As of 12 PM CT on 10/20 we’ve confirmed full resolution of the incident that caused issues with the Built Inspect application for Android, causing it to crash upon opening and/or show 0% inspection completion percentages.
All users of the Built Inspect application for Android should update their apps to the newest version, v4.0.19, to avoid experiencing these issues moving forward.
Thank you for your patience. We apologize for any inconvenience this caused.
Posted Oct 20, 2025 - 12:07 CDT
Update
At approximately 2 PM CT on 10/19 we implemented a fix for the incident that caused issues with the Built Inspect application for Android, causing it to crash upon opening and/or show 0% inspection completion percentages. We are closely monitoring the situation to ensure the issue is fully resolved.
All users of the Built Inspect application for Android should update their apps to the newest version, v4.0.19, to avoid these issues moving forward.
Thank you for your patience during this time. We apologize for any inconvenience this has caused.
Posted Oct 20, 2025 - 10:34 CDT
Update
As of 7:20 PM CT on 10/15, we’ve implemented a temporary fix for the issue causing some inspections submitted via the Built Inspect App for Android to show a 0% completion rate. All known affected inspections have been manually corrected, and we’re actively monitoring to identify and fix any new cases immediately. A permanent fix is in progress.
In the interim, BIA Android users should avoid (1) updating their application to the latest version, and (2) refreshing their schedules while there are pending uploads. Should users have issues with their application crashing, they can delete and redownload it, which should solve the issue. Should users experience the 0% completion rate issue, a lender submitted inspection can be used to properly update the completion percentages.
We apologize for any inconvenience and will keep you informed as we have more information. Thank you for your understanding as we work to permanently resolve this issue.
Posted Oct 17, 2025 - 10:08 CDT
Monitoring
As of 7:20 PM CT on 10/15, we’ve implemented a temporary fix for the issue causing some inspections submitted via the Built Inspect App for Android to show a 0% completion rate. All known affected inspections have been manually corrected, and we’re actively monitoring to address any new cases immediately. A permanent fix is in progress.
In the interim, BIA Android users can avoid this issue by avoiding refreshing their schedules while there are pending uploads. Should the issue occur, a lender submitted inspection can be used to properly update the completion percentages.
We apologize for any inconvenience and will keep you informed as we have more information. Thank you for your understanding as we work to permanently resolve this issue.
Posted Oct 15, 2025 - 19:33 CDT
Identified
We have identified the cause of the incident causing a 0% inspection completion % for some inspections submitted via the Built Inspect App for Android, which began on 10/7. We are working on a solution that will restore full functionality.
In the interim, BIA Android users can avoid this issue by not refreshing their schedule while there are pending uploads.
We apologize for any inconvenience and will keep you informed as we have more information. Thank you for your understanding as we work to resolve the issue.
Posted Oct 15, 2025 - 16:56 CDT
This incident affected: Built Service Availability (Inspection and Progress Reporting, Mobile Applications).