Built Support - Phone Outage

Incident Report for Built Technologies

Resolved

We appreciate your patience and our Support Team is available to take your calls!
Please contact us via phone or in-app chat if you were unable to be assisted during the outage.
Built Support can be reached at 800-655-8138 Monday - Friday from 7AM to 7PM CT.
Posted Jun 12, 2025 - 16:21 CDT

Identified

We are experiencing a temporary outage with our phone lines and are working with our third-party provider to resolve this as soon as possible. Our Support team is available for immediate assistance via in-app chat.
We apologize for this inconvenience and appreciate your patience while we work to get this resolved.
Posted Jun 12, 2025 - 14:45 CDT
This incident affected: Built Service Availability (Authentication and User Management) and Built for Construction (Authentication and User Management).