Payment Management & Project Financials - New User Signup
Incident Report for Built Technologies
Resolved
We have resolved the issue impacting Payment Management and Project Financials, causing issues with user sign up and project acceptance. If you continue to experience issues please reach out to Built Support at (800) 655-8138 or support@getbuilt.com.
Posted Jul 17, 2024 - 13:36 CDT
Investigating
We’ve identified an issue impacting Payment Management and Project Financials, causing issues with new user sign up and project acceptance. We are actively investigating the issue and will provide updates as soon as the issue is resolved. Thank you for your patience and understanding.
Posted Jul 17, 2024 - 12:51 CDT
This incident affected: Built for Construction (Authentication and User Management).