Lien Waiver Outage
Incident Report for Built Technologies
Resolved
We've confirmed full resolution of the issue impacting lien waiver signing in Project Financials, Payment Management and LWIO. Thank you for your patience and understanding.
Posted Jul 15, 2024 - 12:09 CDT
Update
We are continuing to monitor for any further issues.
Posted Jul 15, 2024 - 12:05 CDT
Monitoring
All users of Project Financials, Payment Management and LWIO may have recently experienced issues signing lien waivers. Our third-party vendor appears to have resolved the issue and we continue to actively monitor to ensure full resolution. If you are still experiencing problems, please contact support@getbuilt.com.
Posted Jul 15, 2024 - 11:33 CDT
Investigating
We've identified an issue with a third-party vendor that is impacting the signing of lien waivers. We are actively monitoring the situation and will provide updates as soon as the issue is resolved. Thank you for your patience and understanding.
Posted Jul 15, 2024 - 11:29 CDT
This incident affected: Built for Construction (Lien waivers).