Issue with creating pay applications in BPM/FPM
Incident Report for Built Technologies
Resolved
The issue affecting Built Payment Management and Project Financials has been identified and resolved as of 4 PM CST on Tuesday, January 14th, 2025. Users are now able to successfully create pay applications without any issues.
If you have any questions or continue to experience problems, please contact our support team. Thank you for your patience.
Posted Jan 15, 2025 - 11:30 CST
Identified
The issue affecting Built Payment Management and Project Financials has been identified, and users should now be able to create pay applications. Please note that this may still be an intermittent issue. If you encounter any difficulties, we recommend retrying the action.
If you continue to experience problems or have any questions, please contact our support team.
Thank you for your patience and understanding.
Posted Jan 14, 2025 - 17:17 CST
Investigating
We are currently investigating the cause of an incident identified at 10:50 AM CT impacting Built Payment Management and Project Financials causing issues for some users as they attempt to create a pay application. We apologize for any inconvenience this may cause and are working to resolve the issue as quickly as possible.
Posted Jan 14, 2025 - 11:16 CST
This incident affected: Built for Construction (Lien waivers).