Built site availability and reporting pipelines blocked due to widespread outage

Incident Report for Built

Update

Access to Built continues to be impacted by the widespread Amazon Web Services (AWS) outage affecting many platforms and services today.

While we are beginning to see signs of recovery in some areas of the AWS infrastructure, service has not yet returned to the level of stability and performance required for Built to be fully operational.

We remain in close contact with the AWS team and are working to ensure that our services are restored as soon as the underlying issues are fully resolved. We will continue to monitor progress closely and provide updates as new information becomes available.

Thank you for your continued patience.
Posted Oct 20, 2025 - 17:31 CDT

Update

Access to Built remains blocked by the widespread Amazon Web Services (AWS) outage impacting many websites and platforms today.

We are actively working with the AWS team to ensure that our services are restored as soon as the underlying issues are resolved. While we do not have a confirmed resolution time from AWS yet, we are monitoring the situation closely and will continue to provide updates as more information becomes available.

We sincerely appreciate your continued patience and understanding.
Posted Oct 20, 2025 - 16:54 CDT

Identified

There is a major outage tied to a widespread disruption with Amazon Web Services (AWS), which powers many of the applications and platforms you use daily, including Built.
Our team is actively monitoring the situation and working to restore service as soon as AWS resolves the issue.
We really appreciate your patience during this time and we will keep our status page updated with the latest information.
Posted Oct 20, 2025 - 10:26 CDT

Monitoring

Data processing and integrations are delayed due to a service provider outage. We are seeing recovery and will continue to monitor recovery and provide updates.
Posted Oct 20, 2025 - 06:52 CDT
This incident affects: Built Service Availability (Authentication and User Management, Insights Reporting, Client Data Integrations, Mobile Applications, Desktop Applications) and Built for Construction (Authentication and User Management).