As of approximately 5 PM CT on 1/16 we have confirmed resolution of the issue affecting Built Payment Management and Project Financials, impacting users' abilities to create pay applications.
Thank you for your patience. We apologize for any inconvenience this caused.
Posted Jan 16, 2025 - 17:05 CST
Monitoring
At approximately 2:30 PM CT we implemented a fix for the incident that made users unable to create pay applications in Built Payment Management and Project Financials. We are closely monitoring the situation to ensure the issue is fully resolved. Thank you for your patience during this time. We apologize for any inconvenience this has caused.
Posted Jan 16, 2025 - 14:54 CST
Investigating
We are investigating an issue identified at 11:20 AM CT, making users unable to create pay applications in Built Payment Management and Project Financials. The issue stems from a third-party vendor, and we are working with them to resolve it as quickly as possible. We apologize for the inconvenience and appreciate your patience.
Posted Jan 16, 2025 - 11:47 CST
This incident affected: Built for Construction (Lien waivers).