Newly invited users unable to log into Built

Incident Report for Built

Resolved

As of approximately 7 PM CT on 11/21 we've confirmed resolution of the incident causing new users to encounter an error upon registering with Built. This issue was impacting CLA+, Construction Financials and Construction Payments.

Thank you for your patience during this time. We apologize for any inconvenience this has caused.
Posted Nov 21, 2025 - 18:59 CST

Identified

We have identified the cause of the incident causing new users to encounter an error upon registering with Built. This issue is impacting all products besides CLA.
 
We are working on a solution that will restore full functionality. As a workaround, some users have been able to navigate to https://id.getbuilt.com/logout to log out following sign-up, then log in again without issue.
 
We apologize for any inconvenience and will keep you informed as we have more information. Thank you for your understanding as we work to resolve the issue.
Posted Nov 21, 2025 - 12:42 CST
This incident affected: Built Service Availability (Authentication and User Management).