As of 11 AM CST on 1/9/2026 we’ve confirmed full resolution of the Draw Rule issues impacting CLA+ and Construction Financials for Owners beginning at 3 PM CST on 1/8/2026.
For some users, a refresh may be required in order to see the fix applied.
Thank you for your patience. We apologize for any inconvenience this caused.
Posted Jan 09, 2026 - 11:08 CST
Monitoring
As of 9:40 AM CST on 1/9/2026 we are monitoring the solution that has been implemented to address the incident impacting CLA+ and Construction Financials for Owners, causing the inability to update the status of Draw Rules. We apologize for any inconvenience and will keep you informed as we have more information. Thank you for your understanding as we work to confirm the resolution of the issue.
Posted Jan 09, 2026 - 09:45 CST
Identified
We have identified the cause of the incident causing issues updating the status of Draw Rules in CLA+ and Construction Financials for Owners beginning at roughly 3 PM CST on 1/8/2026. We are working on a solution that will restore full functionality. We apologize for any inconvenience and will keep you informed as we have more information. Thank you for your understanding as we work to resolve the issue.
Posted Jan 09, 2026 - 09:31 CST
This incident affected: Built Service Availability (Accounting and Draw Processing).