We have resolved the issue impacting the ability to submit inspections on the platform. If you did receive an error when trying to submit a Lender Managed inspection, please attempt to resubmit the inspection. We appreciate your patience and should you have any additional questions please contact our Support team at 800-655-8138 or utilize the chat feature in Built.
Posted Aug 12, 2025 - 12:10 CDT
Identified
We’ve identified the issue impacting the ability to submit inspections on the platform. Our team is actively working to address the root cause and implement a fix as quickly as possible. If you did receive an error when trying to submit an inspection, please attempt to resubmit the inspection. We appreciate your patience and will continue to share updates as more information becomes available.
Posted Aug 12, 2025 - 11:57 CDT
Investigating
We’re currently investigating an issue impacting the ability to submit inspections on the platform. Our team is actively working to identify the root cause and implement a fix as quickly as possible. We’ll continue to share updates as more information becomes available.
Posted Aug 12, 2025 - 11:49 CDT
This incident affected: Built Service Availability (Inspection and Progress Reporting).