We’ve confirmed full resolution of the incident. All data has been refreshed and is now up-to-date.
Thank you for your patience. We apologize for any inconvenience this caused.
Posted Oct 31, 2024 - 17:38 CDT
Monitoring
At approximately 2:30 PM CT we implemented a fix for the incident, and all Built products are now fully operational. Data updated between 11:30 AM - 2:30 PM CT is currently being refreshed, so some data discrepancies may still remain.
Thank you for your patience during this time. We will provide a final update to confirm when all data is refreshed and up to date.
Posted Oct 31, 2024 - 15:09 CDT
Identified
We have identified the cause of the incident causing data lags across Built Payment Management and Financial Project Management, impacting Reporting, the Payables grid, and Transaction tab, as well as impacting all notifications and reminders. We are working on a solution that will restore full functionality and will provide updates as soon as we have them.
Posted Oct 31, 2024 - 14:14 CDT
This incident affected: Built for Construction (Payments).