Project Financials - User Interface Issue
Incident Report for Built Technologies
Resolved
We've confirmed full resolution of the issue impacting Project Financials. Thank you for your patience. We apologize for any inconvenience this caused.
Posted Nov 07, 2024 - 11:30 CST
Identified
We have identified the cause of the incident causing the wrong user interface to load when users access Project Financials. We are working on a solution that will restore full functionality.
 
We apologize for any inconvenience and will keep you informed as we have more information. Thank you for your understanding as we work to resolve the issue
Posted Nov 07, 2024 - 11:19 CST
This incident affected: Built for Construction (Lien waivers, Payments).