Issues Accessing Deals

Incident Report for Built Technologies

Resolved

As of 10:15 AM CT on 6/26 we’ve confirmed full resolution of the issue impacting CLA+ and accessing deals, causing users to receive a 404 error message and limit their access to active deals within Built.

Thank you for your patience. We apologize for any inconvenience this caused.
Posted Jun 26, 2025 - 10:16 CDT

Update

At approximately 9:45AM CT on June 26th 2025 we implemented a fix for the incident that caused receive a 404 error message when accessing deals within Built beginning at 9:19 AM CT on June 26th 2025. We are closely monitoring the situation to ensure the issue is fully resolved.

Thank you for your patience during this time. We apologize for any inconvenience this has caused.
Posted Jun 26, 2025 - 09:48 CDT

Monitoring

At approximately 9:45AM CT on June 26th 2025 we implemented a fix for the incident that caused receive a 404 error message when accessing deals within Built beginning at 9:19 AM CT on June 26th 2025. We are closely monitoring the situation to ensure the issue is fully resolved.

Thank you for your patience during this time. We apologize for any inconvenience this has caused.
Posted Jun 26, 2025 - 09:47 CDT

Investigating

We are currently investigating the cause of an incident identified at 9:19 AM CT on June 26th impacting CLA+ and accessing deals, causing users to receive a 404 error message and limit their access to active deals within Built.

At this time we do not know the cause of the incident or have an estimated time for resolution. We will provide updates as we have them, and we appreciate your patience while we work to resolve the issue.
Posted Jun 26, 2025 - 09:42 CDT
This incident affected: Built Service Availability (Deal Management).