Issues signing Lien Waivers and Pay Applications
Incident Report for Built Technologies
Resolved
We have confirmed resolution of this incident and apologize for any inconvenience this may have caused.
Posted Jul 25, 2024 - 20:32 CDT
Identified
We’ve identified an issue with a third-party vendor that is impacting the signing of lien waivers and pay applications. We are actively monitoring the situation and will provide updates as soon as the issue is resolved. Thank you for your patience and understanding.
Posted Jul 25, 2024 - 17:41 CDT
This incident affected: Built for Construction (Lien waivers, Payments).