Inspection Photos and Project Files Not Appearing
Incident Report for Built Technologies
Resolved
We have confirmed that photo and file uploading and viewing is fully recovered in our Draw platform. If you continue to experience any issues, please contact Built Support.
Posted Mar 22, 2023 - 10:40 CDT
Monitoring
We are beginning to see recovery of photos and files uploading and viewable in our Draw platform. The system will take time to work through the queue of photos and files. We will continue to monitor for full recovery.
Posted Mar 22, 2023 - 10:12 CDT
Identified
We have been made aware that some lenders are experiencing issues with uploading and viewing inspection photos and files in Built's Draw platform. We are actively reviewing and confirmed a delay in photos and files appearing, however they are not lost. We will provide an update once available.

We apologize for the inconvenience.
Posted Mar 22, 2023 - 10:03 CDT
This incident affected: Built Service Availability (Inspection and Progress Reporting).