Procore Pay App Sync Issues

Incident Report for Built Technologies

Resolved

As of 9:45 AM CT on 4/2 we’ve confirmed full resolution of the issue that had been blocking the import of projects, commitments, and pay apps from Procore into Built Payment Management. Any failed imports or syncs have been automatically re-run, and your data should be up-to-date.
Posted Apr 02, 2025 - 09:50 CDT

Identified

We have identified the cause of the incident identified at 2:18 PM CT on 4/1 impacting Payment Management, causing some users to be blocked from importing projects and commitments, in addition to syncing pay apps from Procore. We are working on a solution that will restore full functionality and expect to have it implemented by 12 PM CT 4/2.

We apologize for any inconvenience and will keep you informed as we have more information. Thank you for your understanding as we work to resolve the issue.
Posted Apr 01, 2025 - 14:15 CDT
This incident affected: Built for Construction (Payments).